GPG Error Debian Aptitude

Wer bei einem „aptitude update“ auf folgende Fehlermeldung stößt, hat vermutlich keine aktuelle Liste mit gültigen GPG-Schlüsseln mehr auf seinem System:

W: GPG error: http://ftp.de.debian.org lenny Release: Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY AED4B06F473041FA

Um dies zu lösen kann man,nachdem man die Gültigkeit des neuen Schlüssels auf Debian Schlüssl Seite Kontrolliert hat, mit folgendem Komando den neuen Schlüssel laden und aktivieren:

gpg --keyserver subkeys.pgp.net --recv-keys AED4B06F473041FA;gpg --armor --export AED4B06F473041FA| apt-key add -

Nun sollte das „aptitude update“ wieder ohne Probleme funktionieren. Dabei muss eventuell die Schlüssel-ID angepasst werden. Die aktuelle (Stand 15.11.11) für Squeeze ist 4B06F473041, welche sich auf der oben genannten Schlüssel-Seite in erfahrung bringen lässt.

Weiter Inforamtionen zu der Sicherheit von apt(-itude) biete das Debian Wiki